[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [StrongED] Re: StrongED 4.70a13 available



On 2018-10-14 12:21, Chris Newman wrote:

I always use a fresh copy of !StrED_cfg as well as !StrongED in case that's
been updated with the main programme.

I used to keep matched pairs of SE and !StrED_cfg so that whenever I had
more than one instance of SE on my machine either of them (after suitable
unsetting of relevant sys vars) could be run in isolation.

I also fully documented in changes to mode files when I made a change, and what I intended it to achieve, and (where relevant) why I did it that way.
I kept separate notes for changes not made to mode files, too.

When I decided that a newer version of SE should be customised to match an earlier version I reworked each change as required. That's to say that the aim of each wouldn't necessarily be exactly the same as before (because the new SE might have changed the way things worked) and the details of how & why it now worked might also be different. Of course this took quite a while
but it also meant that I never had a confused mix of old & new versions.


It would be helpful for Fred to state whether !StrED_cfg needs to be
updated or we can carry on with the current one.

The problem for Fred is that presumably not everybody installs every
version of SE that he makes available.  So different users' "current"
ones will match different versions of SE.

--
Jeremy Nicoll - my opinions are my own

--
To unsubscribe send a mail to StrongED+unsubscribe@xxxxxxxxxxx
List archives and instructions at
http://stronged.torrens.org/index.html