[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[StrongED] Re: filetype &000



In article <398c669855.jim@xxxxxxxxxxxxxx>,
   Jim Nagel <stred@xxxxxxxxxxxxxxxx> wrote:
> Chris Johnson  wrote on 3 May:

> > In article <99267d7a55.jim@xxxxxxxxxxxxxx>,
> >    Jim Nagel <stred@xxxxxxxxxxxxxxxx> wrote:
> >> Might well be something with the OS or Filer rather than StrongEd,
> >> because sometimes "Set type" from the Filer menu behaves oddly:  if
> >> I try to set type to, say, "Text" or "Obey", it fails; but can
> >> successfully set type to "&fff" or "&feb" -- which of course
> >> translate to Text and Obey.

> > When this happens, do a *show File$Type* in a task window. This
> > should list all the filetype number/name associations. Does this
> > include all the normal filetypes?

> It's happening again today: files saved from StrongEd appear in 
> directory with filetype &000 and length 0 -- and I'm lucky to notice 
> it, lest my work be lost.

> So I do   *show file$type   as Chris suggests.  The result is an empty 
> list!  What is the meaning of this?!

The only way I can think that this has happened is that something has
done a command
    *unset file$type_*
or some contraction of that, where the last characters before the
trailing * were omitted. This would have removed the many OS variables
with that prefix.

But this should not have happened!

Does re-booting resolve the isue?

Martin

-- 
Martin Avison      using a British Iyonix running RISC OS 5 
                   and the Pluto mail and newsreader

--=20
To unsubscribe send a mail to StrongED+unsubscribe@xxxxxxxxxxxxxx
List archives at http://www.Torrens.org.uk/RO/StrongED/index.html