[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [StrongED] Folding on SED V4.70a2

In article <f32841d753.fjgraute@xxxxxxxxx>, Fred Graute
<fjgraute@xxxxxxxxx> wrote:
> In message <93ebd6d653.iyojohn@xxxxxxxxxxxxxxxxxxxxx> John Rickman
>           Iyonix <rickman@xxxxxxxxxxxxx> wrote:

> > Richard Ashbery  wrote
> >
> > > I've just tried to use Folding on a BASIC file with SED V4.70a2
> > > but the folding arrows fail to appear. It used to work on
> > > earlier SED versions. Interestingly Shift + or - reports "Not
> > > in a fold".

> I've tried several 4.69 & 4.70 versions but none of them displayed
> this problem. Make sure that Basic mode is installed

BASIC is installed.

> and that the
> sprites for the fold arrows are present in
> !StrongED.Defaults.Sprites.Sprites[22].

Sprites22 are installed correctly in the above location.

> Does the file fold correctly except for the fold arrows not
> appearing?


> You only see PROC/FN definition but not the actual
> function body?

Yes - I've found it very useful (when it worked) to hide the DEF PROCs.

> It would be useful to have more info on the system used:

>  - type of machine, compatibility mode in case of RPi - screen
>  mode, in particular colour depth - type and name of font

Iyonix RISC OS 5.18/ 16 million cols/1920 x 1200/60Hz.

Raspberry Pi (RISC OS 5.21) 16 million cols/1920 x 1080/30Hz running
in ARMv7 strict mode.

SED 4.70a2 and Bitmap System selected on all machines.

Something odd here - with SED 4.70a2 on the Beagleboard (RISC OS 5.20)
and running an identical colour depth to the Raspberry Pi, Folding
works correctly.

Perhaps I have an obscure software conflict :-(


To unsubscribe send a mail to StrongED+unsubscribe@xxxxxxxxxxxxxx
List archives at http://www.Torrens.org.uk/RO/StrongED/index.html