[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [StrongED] Transient oddity.



In message <05954fcb53.pnyoung@xxxxxxxxxxxxxxxxxxxx>
          Peter Young <pnyoung@xxxxxxxxxxxx> wrote:

> On 16 Jan 2014  Fred Graute <fjgraute@xxxxxxxxx> wrote:
>
> > In message <427b8eca53.pnyoung@xxxxxxxxxxxxxxxxxxxx>
> >           Peter Young <pnyoung@xxxxxxxxxxxx> wrote:
>
> >> On 15 Jan 2014  Fred Graute <fjgraute@xxxxxxxxx> wrote:
> >>
> >>> In message <e4d24bca53.pnyoung@xxxxxxxxxxxxxxxxxxxx>
> >>>           Peter Young <pnyoung@xxxxxxxxxxxx> wrote:
>
> [snip solution of Transient problem]
>
> >> Thanks for the erudite explanation, Fred. It seems that I stumbled on
> >> the correct solution!
>
> > There may be another solution. After writing the above I remembered that
> > ToggleBD had a similar problem which I fixed by creating all the Toolbox
> > objects manually. Doing it that way means you'll get the object's ID on
> > exit from the SWI call and hence no need for Toolbox_ObjectAutoCreated
> > messages.
>
> > This seems to work as I can now place Transient early in the start-up
> > sequence and it runs without error something it didn't do previously.
>
> That sounds interesting. Will there be a new release?.

Yes, there will be shortly now that I've tried it on RO Select and it
seems to be fine there too. Select BTW doesn't seem to have a problem
with the 'old' Transient being run early in the start-up sequence.
Another ROL vs ROOL Toolbox difference?

Cheers,
Fred.

-- 
StrongED Developer
http://www.stronged.iconbar.com/

--
To unsubscribe send a mail to StrongED+unsubscribe@xxxxxxxxxxxxxx
List archives at http://www.Torrens.org.uk/RO/StrongED/index.html