[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [StrongED] Transient with Aemulor on rasPi



In message <323f6ca253.iyojohn@xxxxxxxxxxxxxxxxxxxxx>
          John Rickman Iyonix <rickman@xxxxxxxxxxxxx> wrote:

> Fred Graute  wrote
>
> >> I have just installed AemulorPro in predesk on my RaspberryPi. Now
> >> when I run Transient the machine freezes and requires a power off and
> >> reboot to work again.
> >>
> >> Transient puts its icon on the icon bar with a name of xx-xx-xxxx.
> >> the last few entries in the reporter log are:-
> >>
> >>  Run <Transient$Dir>.!RunImage
> >>  @RunType_FFB SDFS::RISCOSpi$.appz.t1.!Transient.!RunImage
> >>  Basic -quit  "SDFS::RISCOSpi$.appz.t1.!Transient.!RunImage"
> >>  [BASIC/75A03940] Exec
> >>  ..... TaskClose &75C039A0
> >>  Copy <Wimp$ScrapDir>.TranCfg <Choices$Write>.Transient.Choices f_c_v
> >>  Exec
> >>
> >> Any suggestions for a fix, bypass, cause?
>
> > Not really. Transient is just BASIC so shouldn't be affected by
> > AemulorPro. The toolbox modules it uses might be a problem, in
> > particular the Tabs module, but that seems unlikely too.
>
> Thanks for the clue Fred. It appears that there is no Tabs module in
> the ROM toolbox in 5.21 RISCOSpi.

Correct, it's not part of the standard toolbox modules but a very useful
third party one created by Rik Griffin.

> I have copied the Toolbox from my Iyonix and Transient is now working
> (with Aemulor loaded).

The latest version (v2.06) should load the copy inside Transient when
Tabs isn't running and is not present in !System. If you are running
Transient 2.06 and this doesn't happen then that's a bug.

Cheers,
Fred.

-- 
StrongED Developer
http://www.stronged.iconbar.com/

--
To unsubscribe send a mail to StrongED+unsubscribe@xxxxxxxxxxxxxx
List archives at http://www.Torrens.org.uk/RO/StrongED/index.html