[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [StrongED] Re: StrongED and Lua



On 18 Sep 2013  Fred Graute <fjgraute@xxxxxxxxx> wrote:

> In message <b6c3228d53.pnyoung@xxxxxxxxxxxxxxxxxxxx>
>           Peter Young <pnyoung@xxxxxxxxxxxx> wrote:

>> On 16 Sep 2013  Gavin Wraith <gavin@xxxxxxxxxxxxxxx> wrote:
>>
>>>> However, now dragging a Lua script to the Apply icon does simply
>>>> nothing, with plain drag, shift-drag or control-drag! Am I dong
>>>> something wrong, perhaps, or is there a real problem now with doing
>>>> this? Doing this has worked for me in the past.
>>
>>> Had !lua been "seen" by the filer, i.e. filer_booted, when you tried
>>> this? Putting !lua in !Boot.Resources is a good way of ensuring that
>>> this happens at startup.
>>
>> Yes, that's where !lua is, and previously it used to work for me.

> Alternatively, put it anywhere and add it to Boot -> Look at.

>>> I too have StrongED 4.69 and dragging to the Apply icon worked straight
>>> off after I had installed the new version of StrongED. It is the
>>> application !ScriptSED in !StrongED.Defaults.Tools that sorts out
>>> all the dragging to the Apply icon stuff. In !ScriptSED.Languages.lua
>>> the *command "lua" is used. This command gets defined when !lua is
>>> filer_booted. If !lua has not been filer booted then nothing will
>>> happen because the system macro "lua" will be an empty string.
>>
>>> Let me know if this information does not sort your problem out.
>>
>> Yes, the lua tool is indeed in !StrongED.Defaults.Tools, but the
>> scripts still won't run for me.

> Does anything happen?

Nothing at all! And I do have the necessary permissions set in the 
ModeLock file, as has been mentioned.

I'm in off-list contact with Gavin, who is being very helpful, but no 
go yet, I'm afraid.

With best wishes,

Peter.

-- 
Peter Young (zfc W) and family
Prestbury, Cheltenham, Glos. GL52, England
http://pnyoung.orpheusweb.co.uk
pnyoung@xxxxxxxxxxxx

-- 
To unsubscribe send a mail to StrongED+unsubscribe@xxxxxxxxxxxxxx