[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[StrongED] Re: StrongED and Lua

On 16 Sep 2013  Gavin Wraith <gavin@xxxxxxxxxxxxxxx> wrote:

>> I saw in the ANS newsletter that RiscLua 5.70 is available, and went
>> to the website and downloaded it, though in fact it identified itself
>> as 5.60 when it arrived.

> Ouch. Thanks for pointing that out. It was a crucial misprint.
> Download again; it should be OK now.

Many thanks, Gavin; apologies for the slow reply, but I've been busy 
with other things. Very time-consuming, this retirement business.

>> However, now dragging a Lua script to the Apply icon does simply
>> nothing, with plain drag, shift-drag or control-drag! Am I dong
>> something wrong, perhaps, or is there a real problem now with doing
>> this? Doing this has worked for me in the past.

> Had !lua been "seen" by the filer, i.e. filer_booted, when you tried
> this? Putting !lua in !Boot.Resources is a good way of ensuring that
> this happens at startup.

Yes, that's where !lua is, and previously it used to work for me.

> I too have StrongED 4.69 and dragging to the Apply icon worked straight
> off after I had installed the new version of StrongED. It is the
> application !ScriptSED in !StrongED.Defaults.Tools that sorts out
> all the dragging to the Apply icon stuff. In !ScriptSED.Languages.lua
> the *command "lua" is used. This command gets defined when !lua is
> filer_booted. If !lua has not been filer booted then nothing will
> happen because the system macro "lua" will be an empty string.

> Let me know if this information does not sort your problem out.

Yes, the lua tool is indeed in !StrongED.Defaults.Tools, but the 
scripts still won't run for me.

>> I can't find any information about Lua in StrongED's help file

> Well StrongED can potentially cope with any scripting language
> so long as the appropriate Obey file is in !ScriptSED.Languages.
> I do not think Fred has got round to supplying Help files for
> each of the ones supplied.

>> or about StrongED in RiscLua's help file.

> See "transforming text". Alternatively have a look at "Doing more with
> text" ( http://www.wra1th.plus.com/str_ed_ex/a.html ) in a modern
> browser that can show tooltips. It is a bit of a mess in NetSurf
> because that has not implemented the :hover attribute in CSS yet.

> I am afraid the sample Lua scripts supplied in !ScriptSED are a bit
> out of date. Maybe I should make my own available for download from
> my site?

I think that may well be the problem; I seem to remember that the same 
thing happened with a previous update of RiscLua. A download facility 
from the site would be a good idea, I think.

> If you have any problems, feel free to email.

I shall do that, and I need to ask you about a weird problem that I've 
had with !Apply since I updated lua and all the associated programs.

With best wishes,


Peter Young (zfc W) and family
Prestbury, Cheltenham, Glos. GL52, England

To unsubscribe send a mail to StrongED+unsubscribe@xxxxxxxxxxxxxx